Instalando PgAdmin4 no Linux

Resolvendo erro: E: O pacote ‘pgadmin4’ não possui candidato à instalação, E: Package ‘pgadmin4’ has no installation candidate.

😉 Gostou do vídeo, que tal me pagar um cafezinho?

☕ https://picpay.me/dane.infocotidiano​

Doar com PagSeguro: https://pag.ae/7W6uXEqB1

# compatibilidade:

    Debian 9 (Stretch), 10 (Buster), 11 (Bullseye/testing, from v4.30)
    Ubuntu 16.04 (Xenial, up to v4.30), 18.04 (Bionic), 19.10 (Eoan, up to v4.29), 20.04 (Focal), 20.10 (Groovy, from v4.30)
    Se você usa derivado como mint, você muda o nome do repositório de acordo com a hierarquia:
 Exemplo, o Mint 20.1 (ulyssa) é derivado do Ubuntu 20.04 (focal), então lá no arquivo pgadmin4.list
 criado no mint: deb https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/ulyssa pgadmin4 main
 você muda para: deb https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/focal pgadmin4 main

Comandos:


# Instalando chaves:
sudo curl https://www.pgadmin.org/static/packages_pgadmin_org.pub | sudo apt-key add

#Configurar repositorios:
sudo sh -c 'echo "deb https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/$(lsb_release -cs) pgadmin4 main" > /etc/apt/sources.list.d/pgadmin4.list && apt update'

#no linux mint 20.01
edite o arquivo /etc/apt/sources.list.d/pgadmin4.list, voce vai encontrar a linha:
deb https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/ulyssa pgadmin4 main
substitua por esta linha (ou so troque ulyssa por focal):
deb https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/focal pgadmin4 main


#Instalar PgAdmin4 Web e Desktop
sudo apt install pgadmin4:

#Instalar somente desktop:
sudo apt install pgadmin4-desktop

#instalar web
sudo apt install pgadmin4-web 

#Configurar Webserver
sudo /usr/pgadmin4/bin/setup-web.sh

Daniel Morais

Comecei na área de TI há um bom tempo (1991) com aqueles cursos de MS-DOS 6.22, WordStar, Lotus123, Dbase III Plus, etc. Adorei programar em Dbase III Plus utilizando Dbf; achei fantástico quando aprendi a programar em Clipper Summer 87 e posteriormente Clipper 5.x, que era muito estável em rede utilizando Novell NetWare. Desde então sou um fanático por TI. Hoje desenvolvo aplicações para Windows, Android, OS X e Linux utilizando Lazarus (free Pascal) . Blogueiro (www.infocotidiano.com.br, www.aprendalazarus.com.br, www.startdb.com.br). Além dos meus Blogs tenho um canal no YouTube o www.youtube.com.br/infocotidiano onde tenho mais de 1 Milhão de visualizações com vídeos de dicas diversificadas que vão desde solucionar um erro de impressão, curso sobre banco de dados, até criar software multi-plataforma utilizando o Lazarus.

3 thoughts on “Instalando PgAdmin4 no Linux

  • em
    Permalink

    Lamentavelemente para mim nao funcionou. Tenho Ubuntu 20.94 e deu o seguinte erro ja ao Configurar os repositorios:
    The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 8881B2A8210976F2
    Reading package lists… Done
    N: Skipping acquire of configured file ‘main/binary-i386/Packages’ as repository ‘http://apt.postgresql.org/pub/repos/apt focal-pgdg InRelease’ doesn’t support architecture ‘i386’
    W: GPG error: https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/focal pgadmin4 InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 8881B2A8210976F2
    E: The repository ‘https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/focal pgadmin4 InRelease’ is not signed.
    N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

    e depois deu o tipico:
    The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 8881B2A8210976F2
    Reading package lists… Done
    N: Skipping acquire of configured file ‘main/binary-i386/Packages’ as repository ‘http://apt.postgresql.org/pub/repos/apt focal-pgdg InRelease’ doesn’t support architecture ‘i386’
    W: GPG error: https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/focal pgadmin4 InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 8881B2A8210976F2
    E: The repository ‘https://ftp.postgresql.org/pub/pgadmin/pgadmin4/apt/focal pgadmin4 InRelease’ is not signed.
    N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    …de novo
    Se tiver alguma dica agradeco enviar por email.
    Abraco e valeu!

    Resposta
  • em
    Permalink

    vlw mano, não deu para comentar no vídeo no youtube mas vim falar aqui, o meu problema era no terminal pq não estava iniciando, dava o senguinte:

    Comando ‘pgadmin4’ não encontrado, você quis dizer:

    comando ‘pgadmin3’ do deb pgadmin3 (1.22.2-6build1)

    Experimente: sudo apt install

    porem quando vi no seu video que era só tacar na pesquisa, funcionou, apesar de não entrar pelo terminal, onde eu queria pegar o link para entrar pelo navegador, eu consegui entrar pelo proprio pc, obg.

    Resposta

Deixe um comentário

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *